Annunci

#1 2013-03-11 05:26:32

Leandro
Ospite

Errore nell'aggiornamento a 2.4.7

Ciao a tutti,

sto incontrando il seguente problema nell'aggiornamento alla versione 2.4.7 dalle .6 su una debian stabile.

Dopo aver fatto l'aggiornamento non mi appare piwigo ma solo la pagina http://sito/piwigo/upgrade.php?language=it_IT dove mi viene richiesto:

Questa pagina vi propone di aggiornare il vostro database corrispondente alla vecchia versione di Piwigo con la nuova versione. L'assistente all'aggiornamento ha identificato la vostra attuale versione 1.3.0 (o equivalente).

Solo l'amministratore può eseguire l'aggiornamento: fate login.

Solo che non riesco a capire chi sia questo amministratore perché immettendo la password di quello che era l'amministratore di piwigo mi dice sempre e comunque "password non valida".

Che posso fare?

 

#2 2013-03-11 10:31:01

rio
Piwigo Team
Parigi
2006-07-24
1713

Re: Errore nell'aggiornamento a 2.4.7

Ciao,

Rischio di non avere tempo sufficiente oggi per darti tutta la procedura passo a passo.

Per primo, hai sempre accesso al data base?
Nella tua configurazione, era possibile registrasi come utente?

Ti dirò cosa fare a seconda delle risposte che mi darai ...

:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il WIKI e un buon' aiuto per incominciare. Le dritte e personalizzazioni sono nel wiki, tutto e nel wiki!

Non in linea

 

#3 2013-03-11 11:46:50

Leandro
Membro
2013-03-11
3

Re: Errore nell'aggiornamento a 2.4.7

rio ha scritto:

Ciao,

Rischio di non avere tempo sufficiente oggi per darti tutta la procedura passo a passo.

Per primo, hai sempre accesso al data base?
Nella tua configurazione, era possibile registrasi come utente?

Ti dirò cosa fare a seconda delle risposte che mi darai ...

:-))

L'installazione era già attiva da tempo (e funzionava benissimo).

Ho accesso al database, sia come utente che come amministratore (il server è mio) ma non era possibile registrarsi come utente perché è un'installazione casalinga.

Grazie un monte in ogni caso!

Non in linea

 

#4 2013-03-11 14:07:56

rio
Piwigo Team
Parigi
2006-07-24
1713

Re: Errore nell'aggiornamento a 2.4.7

Ok, però, hai la possibilità di creare un utente ... come se fosse qualcuno che si vuole connettere alla tua galleria ?
:-))


-> /<Ä®¿M <-
http://riohome.free.fr
Il WIKI e un buon' aiuto per incominciare. Le dritte e personalizzazioni sono nel wiki, tutto e nel wiki!

Non in linea

 

#5 2013-03-12 09:44:33

Leandro
Membro
2013-03-11
3

Re: Errore nell'aggiornamento a 2.4.7

rio ha scritto:

Ok, però, hai la possibilità di creare un utente ... come se fosse qualcuno che si vuole connettere alla tua galleria ?
:-))

Posso creare un utente però non so come fare perché vengo sempre reindirizzato subito all'aggiornamento

Non in linea

 

#6 2013-03-12 21:32:30

rio
Piwigo Team
Parigi
2006-07-24
1713

Re: Errore nell'aggiornamento a 2.4.7

Ok, niente allora, prova cosi :

Connettiti al DB
Nella tabella piwigo_user cerca la prima riga che dovrebbe avere nella colonna "id" il numero 1
Modifica la riga (tramite l'icona).
Lì, sulla linea denominata "password" modifica la funzione in MD5
Digita la password in chiaro
Registra le modifiche (e non dimenticare la password :-))    )
fine.

Info: La tua password viene immediatamente criptata con la funzione MD5

Ti puoi connettere alla tua galleria

:-))

Se hai un dubbio chiedi, prima di fare :-))

Ultima modifica di rio (2013-03-12 21:33:35)


-> /<Ä®¿M <-
http://riohome.free.fr
Il WIKI e un buon' aiuto per incominciare. Le dritte e personalizzazioni sono nel wiki, tutto e nel wiki!

Non in linea

 

#7 2013-03-17 19:27:09

Leandro
Membro
2013-03-11
3

Re: Errore nell'aggiornamento a 2.4.7

Scusa per il ritardo con il quale rispondo

rio ha scritto:

Ok, niente allora, prova cosi :

Connettiti al DB
Nella tabella piwigo_user cerca la prima riga che dovrebbe avere nella colonna "id" il numero 1
Modifica la riga (tramite l'icona).
Lì, sulla linea denominata "password" modifica la funzione in MD5
Digita la password in chiaro
Registra le modifiche (e non dimenticare la password :-))    )
fine.

Info: La tua password viene immediatamente criptata con la funzione MD5

Ti puoi connettere alla tua galleria

:-))

Se hai un dubbio chiedi, prima di fare :-))

Il server sul quale gira il database (mysql) è con linux e non ha interfaccia grafica. Quali sono i comandi da dare direttamente a mysql per fare quello che indichi?

Non in linea

 

Footer forum

Sito realizzato grazie a FluxBB

github twitter newsletter Donazioni Piwigo.org © 2002-2022 · Contattaci